How to Fix “Your Gstreamer installation is missing a plug-in” on Arch Linux

Recently I encountered a problem regarding missing plugins in Arch Linux. This occurred in Clementine media player and I will show you how you can fix it.

If you check what is required with this command, it will clearly show what is required
sudo pacman -Si clementine
Output:

Optional Deps : gst-plugins-base: "Base" plugin libraries
gst-plugins-good: "Good" plugin libraries
gst-plugins-bad: "Bad" plugin libraries
gst-plugins-ugly: "Ugly" plugin libraries
gst-libav: Libav plugin

As you can now see, we need to install the following plugins which contain MP3 and other codecs required to fix this issue.

sudo pacman -S gst-plugins-good gst-plugins-bad gst-plugins-ugly
Funny enough they are named after the move “The Good, Bad and the Ugly” Hah!

Make sure to restart your media player (whether its VLC/Clementine/JuK etc.)

Leave a Reply

Your email address will not be published. Required fields are marked *

Blue Captcha Image
Refresh

*